summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-19 10:51:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-19 10:51:09 +0100
commitad9b5cd19bfd44fdbce2f279a50886a90df29262 (patch)
tree10dd76838a7caaec387961340fe6364b1e5cd793 /gnu
parente3bba7f720d74320e24e752c9cdcb193a939480c (diff)
downloadguix-ad9b5cd19bfd44fdbce2f279a50886a90df29262.tar.gz
gnu: emacs-evil-multiedit: Update to 1.4.1.
* gnu/packages/emacs-xyz.scm (emacs-evil-multiedit): Update to 1.4.1.
[arguments]<#:phases>: Prevent test suite from downloading packages.  Remove
trailing #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c844a7fb6d..c111f83823 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20770,7 +20770,7 @@ describing the key binding changes.")
 (define-public emacs-evil-multiedit
   (package
     (name "emacs-evil-multiedit")
-    (version "1.3.9")
+    (version "1.4.1")
     (source
      (origin
        (method git-fetch)
@@ -20779,8 +20779,7 @@ describing the key binding changes.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "19h3kqylqzbjv4297wkzzxdmn9yxbg6z4ga4ssrqri90xs7m3rw3"))))
+        (base32 "0iwrfkgs0964kxj3kwi8dqn42flhg2pnp4iswc07xi8ri2lflnkv"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-evil" ,emacs-evil)
@@ -20790,15 +20789,15 @@ describing the key binding changes.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-before 'check 'fix-makefile
+         (add-before 'check 'fix-checks
            (lambda _
              (substitute* "Makefile"
                (("@cask exec ") ""))
-             #t)))
+             (substitute* "test/test-helper.el"
+               (("'\\(evil iedit\\)") "nil")))))
        #:tests? #t
        #:test-command '("make" "test")))
-    (home-page
-     "https://github.com/hlissner/evil-multiedit")
+    (home-page "https://github.com/hlissner/evil-multiedit")
     (synopsis "Multiple cursors for Evil mode")
     (description
      "This plugin was an answer to the lack of proper multiple cursor support