summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-22 10:39:33 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:56 +0100
commitadfe69262f0d96340366f52afb6960676d78a33b (patch)
treee64f4ae4ebd29a65cafbb523d9f53aaad4e447cc /gnu
parent4c03f3e0296b848799139336db25c542ae0a57d2 (diff)
downloadguix-adfe69262f0d96340366f52afb6960676d78a33b.tar.gz
gnu: ruby-range-compressor: Add ruby-sorted-set as an input.
* gnu/packages/ruby.scm (ruby-range-compressor)[native-inputs]: Add
ruby-sorted-set.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5f76c870cb..6653e9c669 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8644,7 +8644,8 @@ better performance than @code{Regexp} and @code{String} methods from the
                 (("(.*add_.*dependency '[_A-Za-z0-9-]+').*" _ stripped)
                  (string-append stripped "\n"))))))))
     (native-inputs
-     (list ruby-rspec))
+     (list ruby-rspec
+           ruby-sorted-set))
     (synopsis "Simple arrays of objects to arrays of ranges compressor")
     (description "RangeCompresses is a tiny library that allows compressing
 arrays of objects into arrays of ranges.  For example, it can turn the