summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2023-04-25 11:34:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-25 11:47:51 +0200
commitaf3daff5ea27837193b968b2a42725fcac586b5f (patch)
tree10cbcada9decb4caf7125fb048cb1686a19a70b6 /gnu
parent8a5b6d53829fb94018c4aba15fc5571a3231c9a4 (diff)
downloadguix-af3daff5ea27837193b968b2a42725fcac586b5f.tar.gz
gnu: Add emacs-xonsh-mode.
* gnu/packages/emacs-xyz.scm (emacs-xonsh-mode): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 14b5a19bd9..2f5d49e99f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35136,6 +35136,31 @@ the TypeScript implementation.")
 service.")
       (license license:expat))))
 
+(define-public emacs-xonsh-mode
+  ;; There is no tagged release yet.
+  (let ((commit "7fa581524533a9b6b770426e4445e571a69e469d")
+        (revision "0"))
+    (package
+      (name "emacs-xonsh-mode")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/seanfarley/xonsh-mode")
+               (commit commit)))
+         (sha256
+          (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/seanfarley/xonsh-mode")
+      (synopsis "Emacs major mode for editing Xonsh files")
+      (description
+       "This package implements a major mode for Xonsh scripts.  The basic
+functionality includes syntax highlight for Xonsh operators.  Files with the
+@file{.xonshrc} or @file{.xsh} extension are automatically opened with this
+mode.")
+      (license license:gpl3+))))
+
 (define-public emacs-monokai-theme
   (package
     (name "emacs-monokai-theme")