summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 15:19:18 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:21 +0200
commitb1c488a4057571e417fe65eebefcfc85ad562ac6 (patch)
treebf8393b09900c71022d9d6d519da20ec813f9449 /gnu
parent3a1a844255353d2a57838f649eacd5fb8a2abad5 (diff)
downloadguix-b1c488a4057571e417fe65eebefcfc85ad562ac6.tar.gz
gnu: Add rust-smallvec-0.6.
* gnu/packages/crates-io.scm (rust-smallvec-0.6): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a85e76c53a..6efd754b6c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5023,6 +5023,33 @@ data type.")
     (properties '((hidden? . #t)))
     (license license:expat)))
 
+(define-public rust-smallvec-0.6
+  (package
+    (name "rust-smallvec")
+    (version "0.6.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "smallvec" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1dyl43rgzny79jjpgzi07y0ly2ggx1xwsn64csxj0j91bsf6lq5b"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-serde" ,rust-serde-1.0))
+       #:cargo-development-inputs
+       (("rust-bincode" ,rust-bincode-1.1))))
+    (home-page "https://github.com/servo/rust-smallvec")
+    (synopsis "Small vector optimization")
+    (description
+     "'Small vector' optimization: store up to a small number of items on the
+stack.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-socket2-0.3
   (package
     (name "rust-socket2")