summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-05 12:06:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:20:19 +0100
commitb5696b91a28e19a6cb0833ddc6bb07ea5a59e8e0 (patch)
treeafc5b0863397508e3c2809a15902f5eb290d806c /gnu
parente2ead49220519fe2b62ec8a04440634c8234b241 (diff)
downloadguix-b5696b91a28e19a6cb0833ddc6bb07ea5a59e8e0.tar.gz
gnu: go-github-com-alecthomas-chroma-v2: Enable all tests.
* gnu/packages/golang-xyz.scm (go-github-com-alecthomas-chroma-v2)
[arguments]: <#:go>: Use go-1.19. <#:phases>: Add
'remove-failing-tetdata-and-cmd-files. Use custom 'check phase.

Change-Id: I76a8fcc8089f55e6645762c49c61219520147281
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c40d376685..b30a35506a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -484,8 +484,24 @@ syntax highlighted HTML, ANSI-coloured text, etc.")
        (sha256
         (base32 "1qgr4gywjks869sc85wb8nby612b8wvsa1dwpsbanjsljq7wq7mp"))))
     (arguments
-     (list #:go go-1.19
-           #:import-path "github.com/alecthomas/chroma/v2"))
+     (list
+      #:go go-1.19
+      #:import-path "github.com/alecthomas/chroma/v2"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-failing-testdata-and-cmd-files
+            (lambda* (#:key import-path #:allow-other-keys)
+              (with-directory-excursion (string-append "src/" import-path)
+                (for-each delete-file-recursively
+                          (list "lexers/testdata/python2/test_complex_file1.actual"
+                                ;; Executible is packed as separate package.
+                                "cmd")))))
+          ;; XXX: Replace when go-build-system supports nested path.
+          (replace 'check
+            (lambda* (#:key import-path tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
     (propagated-inputs
      (list go-github-com-dlclark-regexp2))
     (native-inputs