summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-03-28 10:27:51 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-03-28 12:44:01 +0100
commitb8f6b013b9c764561dd552df23a8a0abc3eba175 (patch)
treed21dbbac15ee12da8e549627dfd259aca4922c1e /gnu
parent4881c7d6972e4b7763cbedd6b772d61b6568beb0 (diff)
downloadguix-b8f6b013b9c764561dd552df23a8a0abc3eba175.tar.gz
gnu: Add python-contexttimer.
* gnu/packages/python-xyz.scm (python-contexttimer): New variable.

Change-Id: I1ed35f1d0190f0e3a60095c7627b6c17552cb4cc
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0e49c105f6..8a6ef23b58 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17497,6 +17497,29 @@ managers.  It also contains additional features that are not part of
 the standard library.")
     (license license:psfl)))
 
+(define-public python-contexttimer
+  (package
+    (name "python-contexttimer")
+    (version "0.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/brouberol/contexttimer")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00a9h06a1wj66935n863qlk4jpl9gvdvzkkhl8xmgqwdkwv0js54"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-decorator python-unittest2))
+    (native-inputs (list python-mock))
+    (home-page "https://github.com/brouberol/contexttimer")
+    (synopsis "Timer as a context manager")
+    (description
+     "This package offers utilities to measure code block or function
+execution time.")
+    (license license:gpl3)))
+
 (define-public python-texttable
   (package
     (name "python-texttable")