summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 21:41:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 21:41:58 +0100
commitb9a5c50d8c92a7ec6f15b2ec9005d1bbd72d1024 (patch)
tree0a1bd44bf98b700b7284952fa7fac6e380e8370f /gnu
parent25f0964c3ece4599787c59638a42ad9190a4da49 (diff)
downloadguix-b9a5c50d8c92a7ec6f15b2ec9005d1bbd72d1024.tar.gz
gnu: Add metal.
* gnu/packages/bioinformatics.scm (metal): New variable.

Change-Id: I70fd30c18303f61a9f6720e70d4b4e57140a7140
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fac29cfa98..95df728bc9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8108,6 +8108,45 @@ probabilistic distances of genome abundance and tetranucleotide frequency.")
     (license (license:non-copyleft "file://license.txt"
                                    "See license.txt in the distribution."))))
 
+(define-public metal
+  (package
+    (name "metal")
+    (version "2011-03-25")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://csg.sph.umich.edu/abecasis/Metal/"
+                           "download/generic-metal-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1bk00hc0xagmq0mabmbb8bykl75qd4kfyirba869h4x6hmn4a0f3"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:make-flags
+      #~(list (string-append "INSTALLDIR=" #$output "/bin") "all")
+      #:phases
+      '(modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (substitute* "Makefile"
+               (("^CFLAGS=") "CFLAGS=-std=c++11 ")))))))
+    (inputs (list zlib `(,zlib "static")))
+    (home-page "http://csg.sph.umich.edu/abecasis/Metal/")
+    (synopsis "Facilitate meta-analysis of large datasets")
+    (description "METAL is a tool for meta-analysis genomewide association
+scans.  METAL can combine either test statistics and standard errors or
+p-values across studies (taking sample size and direction of effect into
+account).  METAL analysis is a convenient alternative to a direct analysis of
+merged data from multiple studies.  It is especially appropriate when data
+from the individual studies cannot be analyzed together because of differences
+in ethnicity, phenotype distribution, gender or constraints in sharing of
+individual level data imposed.  Meta-analysis results in little or no loss of
+efficiency compared to analysis of a combined dataset including data from all
+individual studies.")
+    (license license:bsd-3)))
+
 (define-public minced
   (package
     (name "minced")