summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-25 11:24:41 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:28 +0000
commitbd4c6bbf0a821387687bb16221c59f0c1563a26e (patch)
treeb468c03ceab35c3e4ad056da1920ec4a10c7d996 /gnu
parent548a4ac51cea891f4f5a796fd68e6e752f568a23 (diff)
downloadguix-bd4c6bbf0a821387687bb16221c59f0c1563a26e.tar.gz
gnu: Add go-github-com-tklauser-go-sysconf.
* gnu/packages/golang-xyz.scm (go-github-com-tklauser-go-sysconf): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ad6b8f04e6..1badc3856c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1190,6 +1190,43 @@ Use waterutil with it to work with TUN/TAP packets/frames.")
       (home-page "https://github.com/stathat/go")
       (license license:expat))))
 
+(define-public go-github-com-tklauser-go-sysconf
+  (package
+    (name "go-github-com-tklauser-go-sysconf")
+    (version "0.3.13")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tklauser/go-sysconf")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07vkimncnmh89706s49599h2w9gwa6jyrv70f8ifw90nsh766km9"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.18
+      #:import-path "github.com/tklauser/go-sysconf"
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'remove-failing-tests
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (delete-file-recursively
+                        ;; sysconf_test.go (among others) tries to read the
+                        ;; number of online CPUs using /proc/stat and
+                        ;; /sys/devices/system/cpu/online. These files are not
+                        ;; accessible in the test environment.
+                        (string-append "src/" import-path
+                                       "/cgotest/sysconf_test.go")))))))
+    (propagated-inputs (list go-golang-org-x-sys
+                             go-github-com-tklauser-numcpus))
+    (home-page "https://github.com/tklauser/go-sysconf")
+    (synopsis "Go implementation of @code{sysconf}")
+    (description
+     "This package implements @code{sysconf} and provides the associated
+@code{SC_*} constants to query system configuration values at run time.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-tklauser-numcpus
   (package
     (name "go-github-com-tklauser-numcpus")