summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-06-25 22:28:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:01 +0200
commitc0831eadefa2303a0206c0044f0ab5be492de6d3 (patch)
treef5c8876e45aea35b2bfe4494440d5b10cff1430c /gnu
parent7ec0b32d21d2be18ae5acca2d3a60b046fc64306 (diff)
downloadguix-c0831eadefa2303a0206c0044f0ab5be492de6d3.tar.gz
gnu: skymaker: Use G-expressions.
* gnu/packages/astronomy.scm (skymaker)[arguments]: Rewrite as G-expressions.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 334c040c65..120614d2c0 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -967,13 +967,14 @@ interactively in the plotting window.")
         (base32 "03zvx7c89plp9559niqv5532r233kza3ir992rg3nxjksqmrqvx1"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
-       (list
+     (list
+      #:configure-flags
+       #~(list
         "CPPFLAGS=-fcommon"             ; fix build with GCC 10
         (string-append
-         "--with-fftw-libdir=" (assoc-ref %build-inputs "fftw") "/lib")
+         "--with-fftw-libdir=" #$(this-package-input "fftw") "/lib")
         (string-append
-         "--with-fftw-incdir=" (assoc-ref %build-inputs "fftw") "/include"))))
+         "--with-fftw-incdir=" #$(this-package-input "fftw") "/include"))))
     (inputs
      `(("fftw" ,fftwf)))
     (home-page "https://www.astromatic.net/software/skymaker")