summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-12-29 23:05:14 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:26 +0200
commitc4f9895bfe2ad77be8ca31706d57d7ee2852b6ac (patch)
tree53fc77b7942a2045435b32ef1b78bfaa6b668ad7 /gnu
parent609acbbc298c0ffad1fe960cf768811c313b6dd8 (diff)
downloadguix-c4f9895bfe2ad77be8ca31706d57d7ee2852b6ac.tar.gz
gnu: docbook2x: Fix build.
* gnu/packages/docbook.scm (docbook2x): Build from source and fix build.

Change-Id: Iefc3e068217875b5de5e79369b24a55b573df042
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/docbook.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index cf30b95ab2..02cea45e97 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -923,11 +923,15 @@ Detect the differences in markup between two SGML files.
     (build-system gnu-build-system)
     (arguments
      (list
+      #:make-flags ''("AM_MAKEINFOHTMLFLAGS=\"--no-split\"")
       #:modules '((guix build gnu-build-system)
                   (guix build utils)
                   (srfi srfi-26))
       #:phases
       #~(modify-phases %standard-phases
+          (add-before 'build 'clean
+            (lambda _
+              (invoke "make" "clean")))
           (add-after 'install 'move-doc
             (lambda _
               (let* ((old (string-append #$output "/share/doc"))