summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJames Smith via Guix-patches via <guix-patches@gnu.org>2024-04-23 06:14:07 -0700
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-04-24 09:43:02 +0800
commitc58b443102e92fccfbc204769a57757287e41d11 (patch)
tree9f97985b8da02c2052d5f650383511c315f27af7 /gnu
parent83e6437e92ad056838fe170963d920d446d0e4db (diff)
downloadguix-c58b443102e92fccfbc204769a57757287e41d11.tar.gz
gnu: Add wsbg.
* gnu/packages/wm.scm (wsbg): New variable.

Change-Id: Ia83a7afcbb0879f0f6d604e1d671388a30800265
Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2eecc0ed2a..f2cb77f5bf 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -70,6 +70,7 @@
 ;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2024 chris <chris@bumblehead.com>
 ;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3813,6 +3814,30 @@ notable features include:
 It is inspired by dwm and xmonad.")
       (license license:expat))))
 
+(define-public wsbg
+  (let ((commit "15b0d0f6910ea97b9bcc471695fac07270955dd2")
+        (revision "0")
+        ;; Upstream has no version tags, but meson.build contains the correct
+        ;; version number.
+        (version "0.1.0"))
+    (package
+      (inherit swaybg)
+      (name "wsbg")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/saibier/wsbg")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "15xrnwp54kghigx06y4qmmn1q9f26fx4cawyl4kcbqrrzfbbj1g6"))))
+      (home-page "https://github.com/saibier/wsbg")
+      (synopsis "Workspace wallpaper tool for Sway")
+      (description "Wallpaper utility for Sway with support for per-workspace
+configuration."))))
+
 (define-public yambar-wayland
   (package
     (name "yambar-wayland")