summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-09 15:19:45 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-11 00:32:42 +0200
commitc9fcfef3d4b843f2e0e15030f839cc894510b6ef (patch)
tree39a5de4c39b7e134c4fda5239da468734cb80133 /gnu
parent69095cde82b2930ec9450f06aefcc7415524a615 (diff)
downloadguix-c9fcfef3d4b843f2e0e15030f839cc894510b6ef.tar.gz
gnu: polkit: Remove input labels.
* gnu/packages/polkit.scm (polkit-mozjs)[native-inputs]: Remove labels.
(polkit-duktape)[native-inputs, inputs]: Use 'modify-inputs'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/polkit.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a544439fae..1e2f7cc0d4 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -93,12 +93,12 @@
     (propagated-inputs
      (list glib)) ; required by polkit-gobject-1.pc
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("glib:bin" ,glib "bin") ; for glib-mkenums
-       ("intltool" ,intltool)
-       ("gobject-introspection" ,gobject-introspection)
-       ("libxslt" ,libxslt) ; for man page generation
-       ("docbook-xsl" ,docbook-xsl))) ; for man page generation
+     (list pkg-config
+           `(,glib "bin")                         ;for glib-mkenums
+           intltool
+           gobject-introspection
+           libxslt                                ;for man page generation
+           docbook-xsl))                          ;for man page generation
     (arguments
      `(#:configure-flags '("--sysconfdir=/etc"
                            "--enable-man-pages"
@@ -170,13 +170,11 @@ for unprivileged applications.")
                (lambda _
                  (delete-file "configure")))))))
       (native-inputs
-       (append `(("autoconf" ,autoconf)
-                 ("automake" ,automake)
-                 ("libtool" ,libtool)
-                 ("pkg-config" ,pkg-config))
-           (package-native-inputs base)))
-      (inputs (alist-replace "mozjs" `(,duktape)
-                             (package-inputs base))))))
+       (modify-inputs (package-native-inputs base)
+         (prepend autoconf automake libtool)))
+      (inputs
+       (modify-inputs (package-inputs base)
+         (replace "mozjs" duktape))))))
 
 (define polkit-for-system
   (mlambda (system)