summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRostislav Svoboda <rostislav.svoboda@gmail.com>2023-02-24 15:18:14 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-08 16:13:10 +0100
commitca0a4a9dc27119538ea9b05fa886b0f728549796 (patch)
tree1ec0a0f5cc965b1e3219fb3dca3d7ffb532b7287 /gnu
parent79a215fedaf184e552dda86ab7d6e6ff9c408b87 (diff)
downloadguix-ca0a4a9dc27119538ea9b05fa886b0f728549796.tar.gz
gnu: Add emacs-ac-ispell.
* gnu/packages/emacs-xyz.scm (emacs-ac-ispell): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b3edcc21ae..0665fc3c39 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -264,6 +264,29 @@
 ;;; Emacs hacking.
 ;;;
 
+(define-public emacs-ac-ispell
+  (let ((commit "22bace7387e9012002a6a444922f75f9913077b0")
+        (revision "1"))
+    (package
+      (name "emacs-ac-ispell")
+      (version (git-version "0.07" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsorphanage/ac-ispell")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1cq73bdv3lkn8v3nx6aznygqaac9s5i7pvirl8wz9ib31hsgwpbk"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-auto-complete))
+      (home-page "https://github.com/emacsorphanage/ac-ispell")
+      (synopsis "Ispell and Aspell completion source for Auto Complete")
+      (description
+       "AC Ispell is an Ispell and Aspell completion source for Auto Complete.")
+      (license license:gpl3+))))
+
 (define-public emacs-cfrs
   (package
     (name "emacs-cfrs")