summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:50:20 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:13:42 +0100
commitcad3698635f1687d01ba54545d7f8512f8c402b9 (patch)
treeb6a4a3cf6707b345f8d1518ad8a7e865d84da2c9 /gnu
parent0806c87cb288b90b99bf2620e03beaad25a4b4dd (diff)
downloadguix-cad3698635f1687d01ba54545d7f8512f8c402b9.tar.gz
gnu: Remove ocaml4.07-stdio.
* gnu/packages/ocaml.scm (ocaml4.07-stdio): Remove variable.
(ocaml-stdio)[properties]: Remove variant.

Change-Id: I5a664b5130408eba41266f36cfc03641e2a8fd9d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 82d6aec9a8..f750159c1d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6090,7 +6090,6 @@ is now @code{Ocaml_common.Ast_helper}.")
     (propagated-inputs
      (list ocaml-base ocaml-sexplib0))
     (arguments `(#:tests? #f)) ;no tests
-    (properties `((ocaml4.07-variant . ,(delay ocaml4.07-stdio))))
     (synopsis "Standard IO library for OCaml")
     (description
      "Stdio implements simple input/output functionalities for OCaml.  It
@@ -6098,16 +6097,6 @@ re-exports the input/output functions of the OCaml standard libraries using
 a more consistent API.")
     (license license:expat)))
 
-(define-public ocaml4.07-stdio
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-stdio)
-     (version "0.11.0")
-     (source
-      (janestreet-origin "stdio" version
-                         "0pqbp2wy5fgmc38irwvmj9nlcvclb1ix1mp4y7l39bgvvlz303h9"))
-     (properties '()))))
-
 (define-public ocaml-ppx-deriving
   (package
     (name "ocaml-ppx-deriving")