summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-30 21:25:04 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:19 +0200
commitcca8a27461a14c523de6a7411e1ab067a176f06f (patch)
tree4fa8b6e6bcbc7daa420de12fa209d4f3eadbd7e0 /gnu
parent2402df01a62966ff7065c32821d01ea35f5bd5c1 (diff)
downloadguix-cca8a27461a14c523de6a7411e1ab067a176f06f.tar.gz
gnu: texlive-libkpathsea: Remove duplicate documentation.
* gnu/packages/tex.scm (texlive-libkpathsea)[arguments]<#:phases>: Replace
useless `install' phase instead of adding a new one after it.  Delete
documentation already included in another package.

Change-Id: I2c1f1ff12ab24792370f45adc94f056c1ffadec9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 104fa11493..767375c7bd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -241,10 +241,17 @@
             (lambda _
               (substitute* "texk/kpathsea/config.h"
                 (("#define ST_NLINK_TRICK") ""))))
-          (add-after 'install 'post-install
+          (replace 'install
             (lambda _
               (with-directory-excursion "texk/kpathsea"
-                (invoke "make" "install")))))))
+                (invoke "make" "install"))))
+          (add-after 'install 'remove-documentation
+            ;; Documentation is provided by TEXLIVE-KPATHSEA, in a dedicated
+            ;; "doc" output.  Remove duplicates.
+            (lambda _
+              (with-directory-excursion #$output
+                (for-each delete-file-recursively
+                          '("share/info" "share/man"))))))))
     (native-search-paths
      (list (search-path-specification
             (variable "GUIX_TEXMF")