summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-08 00:51:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-08 00:51:48 +0100
commitcd6879cf97000ee4ee554273b12d25f8bee27b66 (patch)
tree3406db8cf0d171fb4cf69dc201ae06c0af16c3fc /gnu
parent70b76c47b0442d9b54c26b398b7be7bba06ab4f1 (diff)
downloadguix-cd6879cf97000ee4ee554273b12d25f8bee27b66.tar.gz
gnu: thinkfan: Use G-expressions.
* gnu/packages/linux.scm (thinkfan)[arguments]<#:configure-flags, #:phases>:
Use G-expressions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3f68063bdd..05dc1b6384 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5909,34 +5909,32 @@ feature, and a laptop with an accelerometer.  It has no effect on SSDs.")
         (base32 "07l7cxbsyvy7awa1zk0zxng60749idvsx3535iginhkqxfzij4b9"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:modules ((guix build cmake-build-system)
+     (list
+      #:modules '((guix build cmake-build-system)
                   (guix build utils)
                   (srfi srfi-26))
-       #:tests? #f                      ; no test target
-       #:configure-flags
-       ;; Enable reading temperatures from hard disks via S.M.A.R.T.
-       ;; Upstream ‘defaults to OFF because libatasmart seems to be horribly
-       ;; inefficient’.
-       `("-DUSE_ATASMART:BOOL=ON")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'create-init-scripts
-           ;; CMakeLists.txt relies on build-time symptoms of OpenRC and
-           ;; systemd to patch and install their service files.  Fake their
-           ;; presence rather than duplicating the build system below.  Leave
-           ;; things like ‘/bin/kill’ because they're not worth a dependency.
-           ;; The sysvinit needs manual patching, but since upstream doesn't
-           ;; even provide the option to install it: don't.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out   (assoc-ref outputs "out"))
-                    (share (string-append out "/share/" ,name)))
-               (substitute* "CMakeLists.txt"
-                 (("pkg_check_modules\\((OPENRC|SYSTEMD) .*" _ package)
-                  (format #f "option(~a_FOUND \"Faked\" ON)\n" package))
-                 ;; That was easy!  Now we just need to fix the destinations.
-                 (("/etc" directory)
-                  (string-append out directory)))
-               #t))))))
+      #:tests? #f                       ; no test target
+      #:configure-flags
+      ;; Enable reading temperatures from hard disks via S.M.A.R.T.
+      ;; Upstream ‘defaults to OFF because libatasmart seems to be horribly
+      ;; inefficient’.
+      #~(list "-DUSE_ATASMART:BOOL=ON")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'create-init-scripts
+            ;; CMakeLists.txt relies on build-time symptoms of OpenRC and
+            ;; systemd to patch and install their service files.  Fake their
+            ;; presence rather than duplicating the build system below.  Leave
+            ;; things like ‘/bin/kill’ because they're not worth a dependency.
+            ;; The sysvinit needs manual patching, but since upstream doesn't
+            ;; even provide the option to install it: don't.
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("pkg_check_modules\\((OPENRC|SYSTEMD) .*" _ package)
+                 (format #f "option(~a_FOUND \"Faked\" ON)\n" package))
+                ;; That was easy!  Now we just need to fix the destinations.
+                (("/etc" directory)
+                 (string-append #$output directory))))))))
     (native-inputs
      (list pkg-config))
     (inputs