summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:07 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:04:29 +0100
commitcdca7347756e4ae230bbe2d6795451e649bc634e (patch)
tree6b966b7dc90d7a284706a2560b7e609b61a00da5 /gnu
parentc60fae72d874203e2d3a21e51a6961358926be99 (diff)
downloadguix-cdca7347756e4ae230bbe2d6795451e649bc634e.tar.gz
gnu: Add ocaml-optint.
* gnu/packages/ocaml.scm (ocaml-optint): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b9f6bb13df..1d30eadd92 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2745,6 +2745,31 @@ for mapping files in memory.  This function is the same as the
 Typical applications are searches, schedulers and caches.")
     (license license:isc)))
 
+(define-public ocaml-optint
+  (package
+    (name "ocaml-optint")
+    (version "0.3.0")
+    (home-page "https://github.com/mirage/optint")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url home-page)
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256 (base32
+                 "1qj32bcw1in7s6raxdvbmjr3lvj99iwv98x1ar9cwxp4zf8ybfss"))))
+    (build-system dune-build-system)
+    (arguments `(#:test-target "."))
+    (native-inputs (list ocaml-crowbar ocaml-monolith ocaml-fmt))
+    (synopsis "Efficient integer types on 64-bit architectures for OCaml")
+    (description
+     "This OCaml library provides two new integer types, @code{Optint.t} and
+@code{Int63.t}, which guarantee efficient representation on 64-bit
+architectures and provide a best-effort boxed representation on 32-bit
+architectures.")
+    (license license:isc)))
+
 (define-public ocaml-lwt
   (package
     (name "ocaml-lwt")