summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-08 23:26:39 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-08 23:35:46 +0100
commitce98c3436c57e7b366a3ec06c47a7e8919c990fb (patch)
treee968020b12fe38dead23df069428b678021dc902 /gnu
parentb55451492742e5632ee0afa0d6ebbe84fb6c6f3d (diff)
downloadguix-ce98c3436c57e7b366a3ec06c47a7e8919c990fb.tar.gz
gnu: python-duckdb: Update to 1.0.0.
* gnu/packages/python-xyz.scm (python-duckdb): Update to 1.0.0.
[propagated-inputs]: Add python-adbc-driver-manager.
[native-inputs]: Remove python-mypy; add python-pytest-xdist.

Change-Id: I506e786d73767b73c34ec0d475e535a4eba51ca2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 18 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1eb8cbe569..7f485a7a97 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23327,23 +23327,33 @@ efficient as possible on all supported Python versions.")
 Mustache templating language renderer.")
     (license license:expat)))
 
+;; XXX: Try to inherit from duckdb and build from source with all extentions.
 (define-public python-duckdb
   (package
     (name "python-duckdb")
-    (version "0.8.1")
+    (version "1.0.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "duckdb" version))
               (sha256
                (base32
-                "1sgfmii5xlkbx3hzyjxg80gl2ni1rxpabahl4gww9by2mgs3fkd5"))))
+                "0lyl6di1c7j31i2mk384j711kzyyf9rjd3nqx5mbgmf7gfvmk852"))))
     (build-system pyproject-build-system)
     (arguments
      (list
       #:test-flags
-      '(list "--ignore=tests/slow/test_h2oai_arrow.py"
-             ;; Don't install anything, thank you.
-             "-k" "not test_install_non_existent_extension")
+      '(list "--numprocesses" "auto"
+             "--ignore=tests/slow/test_h2oai_arrow.py"
+             ;; Do not relay on mypy.
+             "--ignore=tests/stubs/test_stubs.py"
+             "-k" (string-append
+                   ;; Don't install anything, thank you.
+                   "not test_install_non_existent_extension"
+                   ;; See <https://github.com/duckdb/duckdb/issues/11961>.
+                   " and not test_fetchmany"
+                   ;; See <https://github.com/duckdb/duckdb/issues/10702>.
+                   " and not test_connection_interrupt"
+                   " and not test_query_interruption"))
       #:phases
       #~(modify-phases %standard-phases
           ;; Tests need this
@@ -23362,17 +23372,19 @@ Mustache templating language renderer.")
                                "pyfilesystem.hpp"
                                "pybind11/conversions/pyconnection_default.hpp")
                   (("const_name") "_"))))))))
+    (propagated-inputs
+     (list python-adbc-driver-manager))
     (native-inputs
      (list pybind11
            python-fsspec
            python-google-cloud-storage
-           python-mypy
            python-numpy
            python-pandas
            python-psutil
            python-pyarrow
            python-pytest
            python-pytest-runner
+           python-pytest-xdist
            python-setuptools-scm))
     (home-page "https://www.duckdb.org")
     (synopsis "DuckDB embedded database")