summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarco Rimoldi <rimarko@libero.it>2024-02-21 20:30:33 +0100
committerChristopher Baines <mail@cbaines.net>2024-03-16 10:03:55 +0000
commitcf0f8918f654584f544e8618f8d84c47e940ead0 (patch)
tree8b43c4a993bc24bba622470efa201134ad582cde /gnu
parentd99cec308c87c0bd8a5901d7a4a045bc54e902f7 (diff)
downloadguix-cf0f8918f654584f544e8618f8d84c47e940ead0.tar.gz
gnu: python-pyportmidi: Update to 0.0.7-0.d9e5ee0.
When the PortMidi project moved to GitHub in 2021, changing version numbering
scheme, the Python bindings were moved to a separate repository and marked as
needing a new maintainer.  The chosen revision, dated June 2023, is the first
to allow the package to build successfully in the temporary lack of an
official new release.

* gnu/packages/music.scm (python-pyportmidi): Source moved, fix build.
[version]: Change to new scheme, jumping from 217 to 0.0.7.
[source]: Change origin from Sourceforge to GitHub.

Change-Id: Ibe02edca39731f3f3c9001818665d2da97df9465
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm52
1 files changed, 22 insertions, 30 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 84ccad9641..1bc563a190 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3041,36 +3041,28 @@ using a system-independent interface.")
     (license license:expat)))
 
 (define-public python-pyportmidi
-  (package
-    (name "python-pyportmidi")
-    (version (package-version portmidi))
-    (source (package-source portmidi))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f ; no tests included
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'enter-dir
-           (lambda _ (chdir "pm_python") #t))
-         (add-after 'enter-dir 'fix-setup.py
-           (lambda _
-             (substitute* "setup.py"
-               ;; Use Python 3 syntax
-               (("print (\".*\")" _ text)
-                (string-append "print(" text ")\n"))
-               ;; TODO.txt and CHANGES.txt don't exist
-               (("CHANGES =.*") "CHANGES = \"\"\n")
-               (("TODO =.*") "TODO = \"\"\n"))
-             #t)))))
-    (inputs
-     (list portmidi alsa-lib))
-    (native-inputs
-     (list python-cython unzip))
-    (home-page "https://portmedia.sourceforge.net/portmidi/")
-    (synopsis "Python bindings to PortMidi")
-    (description
-     "This package provides Python bindings to the PortMidi library.")
-    (license license:expat)))
+  (let ((commit "d9e5ee00b208b09618fa0d4a5bbce3c9c077b386")
+        (revision "0"))
+    (package
+      (name "python-pyportmidi")
+      (version (git-version "0.0.7" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/PortMidi/pm_python")
+               (commit commit)))
+         (sha256
+          (base32 "1jvp9na8d1hw46w9ybhkimbavfb3ysw7hp30cbk6dj40k5y5vgvz"))
+         (file-name (git-file-name name version))))
+      (build-system python-build-system)
+      (inputs (list portmidi alsa-lib))
+      (native-inputs (list python-cython))
+      (home-page "https://github.com/PortMidi")
+      (synopsis "Python bindings to PortMidi")
+      (description
+       "This package provides Python bindings to the PortMidi library.")
+      (license license:expat))))
 
 (define-public frescobaldi
   (package