summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-03 18:31:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-03 22:28:49 +0200
commitd00b83fb8a49581f08dc5676322c5decdcc64dfd (patch)
tree4601382b97dc4591dcdddf94f19ea795a824945d /gnu
parentf319409be0dd93b4a8aac5744f21512be2a00ed0 (diff)
downloadguix-d00b83fb8a49581f08dc5676322c5decdcc64dfd.tar.gz
gnu: python-soupsieve: Fix python2 variant.
* gnu/packages/python-xyz.scm (python-soupsieve)[properties]: New field.
(python2-soupsieve): Inherit using STRIP-PYTHON2-VARIANT.
[propagated-inputs]: Inherit from BASE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 396010c646..bd706703c8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5443,14 +5443,17 @@ Soup 4.  It aims to provide selecting, matching, and filtering using modern
 CSS selectors.  Soup Sieve currently provides selectors from the CSS level 1
 specifications up through the latest CSS level 4 drafts and beyond (though
 some are not yet implemented).")
+    (properties `((python2-variant . ,(delay python2-soupsieve))))
     (license license:expat)))
 
 (define-public python2-soupsieve
-  (let ((base (package-with-python2 python-soupsieve)))
+  (let ((base (package-with-python2 (strip-python2-variant python-soupsieve))))
     (package
       (inherit base)
       (propagated-inputs
-       `(("python2-backports-functools-lru-cache" ,python2-backports-functools-lru-cache))))))
+       `(("python2-backports-functools-lru-cache"
+          ,python2-backports-functools-lru-cache)
+         ,@(package-propagated-inputs base))))))
 
 (define-public python-netifaces
   (package