summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:28:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:43 +0200
commitd10dbd13cad19885c6b168d7b7605d9903884d78 (patch)
treeb408683a3ab1f878f2a5df33bec64f8866610f47 /gnu
parentff5d2d0ed962c4fdae797a31985aebe7e06692e5 (diff)
downloadguix-d10dbd13cad19885c6b168d7b7605d9903884d78.tar.gz
gnu: Add texlive-ltb2bib.
* gnu/packages/tex.scm (texlive-ltb2bib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index db500a9d75..cc4068e241 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12542,6 +12542,28 @@ LaTeX2e}.")
 several languages not included in that package: BUGS, JAGS, and Stan.")
     (license license:lppl1.3+)))
 
+(define-public texlive-ltb2bib
+  (package
+    (name "texlive-ltb2bib")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ltb2bib/" "source/latex/ltb2bib/"
+                   "tex/latex/ltb2bib/")
+             (base32
+              "1wrm89bynjm4g4a1zpx38v6yd2l3b1gh13h4m5hknvla2lydljfg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ltb2bib")
+    (synopsis "Converts @code{amsrefs} bibliographical databases to BibTeX
+format")
+    (description
+     "This package implements a LaTeX command that converts an @code{amsrefs}
+bibliographical database (@file{.ltb}) to a BibTeX bibliographical database
+(@file{.bib}).  @code{ltb2bib} is the reverse of the @samp{amsxport} option in
+@code{amsrefs}.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-lyluatex
   (package
     (name "texlive-lyluatex")