summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-21 21:04:45 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 10:39:26 -0400
commitd16826cc32ba821e17236dea0536da7200947c97 (patch)
tree89fb43b78f0251cb90a7be85c88d80eb6335dc5a /gnu
parent192426f2f6d81544ebac525080824d96f3382a4d (diff)
downloadguix-d16826cc32ba821e17236dea0536da7200947c97.tar.gz
gnu: Add python-ccdproc.
* gnu/packages/astronomy.scm (python-ccdproc): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index cf83d31340..6133b19e6b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2019 by Amar Singh <nly@disroot.org>
 ;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
 ;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2021, 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021-2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
@@ -1346,6 +1346,37 @@ be as fast as possible so some of the readability has been sacrificed,
 specifically in the C code.")
     (license license:bsd-3)))
 
+(define-public python-ccdproc
+  (package
+    (name "python-ccdproc")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ccdproc" version))
+       (sha256
+        (base32 "0fy1sni87cr05dkljd8wb7vgh7z9agh8wv5kiagxcpbcf8l06jv1"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; FIXME: Test failed a lot with: DeprecationWarning: distutils Version
+     ;; classes are deprecated. Use packaging.version instead (see:
+     ;; https://github.com/astropy/ccdproc/issues/805).
+     (list #:tests? #f))
+    (native-inputs (list python-memory-profiler python-pytest-astropy))
+    (propagated-inputs
+     (list python-astropy
+           python-astroscrappy
+           python-numpy
+           python-reproject
+           python-scikit-image
+           python-scipy))
+    (home-page "http://ccdproc.readthedocs.io/")
+    (synopsis "Basic data reductions of CCD images")
+    (description "The ccdproc package provides many of the necessary tools for
+processing of CCD images built on a framework to provide error propagation and
+bad pixel tracking throughout the reduction process.")
+    (license license:bsd-3)))
+
 (define-public python-cdflib
   (package
     (name "python-cdflib")