summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-04-22 11:43:17 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-26 16:48:58 +0100
commitd2a1a4efad4f1ee5b92320bdd7146411184652f9 (patch)
tree4d5f7a45c14d1583644235060299764d8fec2f31 /gnu
parented0ecceab83a7a5edbe15ded585c7e42c06ba84a (diff)
downloadguix-d2a1a4efad4f1ee5b92320bdd7146411184652f9.tar.gz
gnu: php: Update to 8.3.6.
* gnu/packages/php.scm (php): Update to 8.3.6.

Change-Id: I8f173558fc4098d6d72b42724e5e106d7dabb62a
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/php.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 8419ac033b..72201770c7 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -62,7 +62,7 @@
 (define-public php
   (package
     (name "php")
-    (version "8.2.13")
+    (version "8.3.6")
     (home-page "https://www.php.net/")
     (source (origin
               (method url-fetch)
@@ -70,7 +70,7 @@
                                   "php-" version ".tar.xz"))
               (sha256
                (base32
-                "0js5bm8r3kngsgmxhyr681vrpl4gib3318k8428pigqp06hvna96"))
+                "1bjygxjaqmvccyk4ic3lrca5j34f0pjb6f1ldmi9gbr345mkij2k"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
@@ -278,7 +278,10 @@
                          ;; PCRE with/without JIT gives different result
                          "ext/pcre/tests/gh11374.phpt"
                          "ext/pcre/tests/gh11956.phpt"
-
+                         ;; reported bug only seems to affect windows
+                         "ext/standard/tests/directory/bug74589_utf8.phpt"
+                         ;; this test seems to be unreliable/flaky
+                         "sapi/cli/tests/php_cli_server_pdeathsig.phpt"
                          ;; This test fails on most architectures.
                          "sapi/cli/tests/upload_2G.phpt"))