summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-31 14:34:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:31 +0300
commitd5a8b9a5c262b3c81ea1ef436af65c3f8e93d74d (patch)
tree02030346a70fa93bce4d5184bc913b29d4627ec8 /gnu
parent816f243db05bf9230d594f1260dd83b5f32931a1 (diff)
downloadguix-d5a8b9a5c262b3c81ea1ef436af65c3f8e93d74d.tar.gz
gnu: Add rust-typetag-impl-0.2.
* gnu/packages/crates-io.scm (rust-typetag-impl-0.2): New variable.

Change-Id: I86ef7c9373912193c5a3204c8de172f4a562bb0f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index af436f3df3..002f8cba21 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83380,6 +83380,28 @@ implementation is incomplete.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-typetag-impl-0.2
+  (package
+    (name "rust-typetag-impl")
+    (version "0.2.16")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "typetag-impl" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1cabnvm526bcgh1sh34js5ils0gz4xwlgvwhm992acdr8xzqhwxc"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-syn" ,rust-syn-2))))
+    (home-page "https://github.com/dtolnay/typetag")
+    (synopsis "Implementation detail of the typetag crate")
+    (description
+     "This package provides the implementation detail of the typetag crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-typewit-1
   (package
     (name "rust-typewit")