summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-03-19 15:57:02 +0100
committerAndreas Enge <andreas@enge.fr>2024-04-29 16:37:51 +0200
commitd6a6e832e6e318eec0c4866fdde62ae47f29defa (patch)
treea508e36f6470469f23a8c603a2a5faac1258d561 /gnu
parent50e3fb1ee9407ade5c08db85ffeb3663196a574f (diff)
downloadguix-d6a6e832e6e318eec0c4866fdde62ae47f29defa.tar.gz
gnu: ntl: Correct license.
* gnu/packages/algebra.scm (ntl)[license]: Set to lgpl2.1+.
[source]: Remove trailing #t in snippet.

Change-Id: Ibfcb520aa7fe71087adf2352b4051185a0d6f11e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index eabfc2bf46..ad1e70c62c 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -529,8 +529,7 @@ these types and other mathematical functions.")
             (modules '((guix build utils)))
             (snippet
              '(begin
-                (delete-file-recursively "src/libtool-origin")
-                #t))))
+                (delete-file-recursively "src/libtool-origin")))))
    (build-system gnu-build-system)
    (native-inputs
     (list libtool perl)) ; for configuration
@@ -558,7 +557,8 @@ these types and other mathematical functions.")
     "NTL is a C++ library providing data structures and algorithms
 for manipulating signed, arbitrary length integers, and for vectors,
 matrices, and polynomials over the integers and over finite fields.")
-   (license license:gpl2+)
+   (license license:lgpl2.1+) ; Linking with gf2x makes the distributed
+                              ; binary de facto gpl3+.
    (home-page "https://shoup.net/ntl/")))
 
 (define-public singular