summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 15:47:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:59 +0200
commitd77dad8e1d5c74c9a3625d495362ab5a0dcbb202 (patch)
treec0a70e9a6143e4c31b30d96a98be06fe74ea058d /gnu
parentf08ce35a8f7ebdb64194cdd58ed5259facddc5ce (diff)
downloadguix-d77dad8e1d5c74c9a3625d495362ab5a0dcbb202.tar.gz
gnu: rust-universal-hash: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-universal-hash-0.5,
rust-universal-hash-0.4, rust-universal-hash-0.3): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: I4ccca652dc09ab4b99f2bf072de61b80227700c8
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-crypto.scm61
-rw-r--r--gnu/packages/crates-io.scm61
2 files changed, 61 insertions, 61 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 36693d5212..e1dc086619 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3481,3 +3481,64 @@ cryptographic implementations.")
     (description
      "This package provides the Tiger cryptographic hash function.")
     (license (list license:expat license:asl2.0))))
+
+(define-public rust-universal-hash-0.5
+  (package
+    (name "rust-universal-hash")
+    (version "0.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "universal-hash" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1sh79x677zkncasa95wz05b36134822w6qxmi1ck05fwi33f47gw"))
+       (snippet
+        #~(begin (use-modules (guix build utils))
+           (substitute* "Cargo.toml"
+             (("=2\\.4\\.1") "^2.4.1"))))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-crypto-common" ,rust-crypto-common-0.1)
+        ("rust-subtle" ,rust-subtle-2))))
+    (home-page "https://github.com/RustCrypto/traits")
+    (synopsis "Trait for universal hash functions")
+    (description "This package provides traits for universal hash functions.")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-universal-hash-0.4
+  (package
+    (inherit rust-universal-hash-0.5)
+    (name "rust-universal-hash")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "universal-hash" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "00hljq64l0p68yrncvyww4cdgkzpzl49vrlnj57kwblkak3b49l3"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-generic-array" ,rust-generic-array-0.14)
+        ("rust-subtle" ,rust-subtle-2))))))
+
+(define-public rust-universal-hash-0.3
+  (package
+    (inherit rust-universal-hash-0.4)
+    (name "rust-universal-hash")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "universal-hash" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "00aa241pab99z66f0s464vdrxnk3igs8z1qm6j01chcv5w7r036z"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-generic-array" ,rust-generic-array-0.12)
+        ("rust-subtle" ,rust-subtle-2))))))
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7cd94fc925..cc229dc853 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -78621,67 +78621,6 @@ whitespace from a string.")
 clear display in the output.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-universal-hash-0.5
-  (package
-    (name "rust-universal-hash")
-    (version "0.5.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "universal-hash" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1sh79x677zkncasa95wz05b36134822w6qxmi1ck05fwi33f47gw"))
-       (snippet
-        #~(begin (use-modules (guix build utils))
-           (substitute* "Cargo.toml"
-             (("=2\\.4\\.1") "^2.4.1"))))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-crypto-common" ,rust-crypto-common-0.1)
-        ("rust-subtle" ,rust-subtle-2))))
-    (home-page "https://github.com/RustCrypto/traits")
-    (synopsis "Trait for universal hash functions")
-    (description "This package provides traits for universal hash functions.")
-    (license (list license:expat license:asl2.0))))
-
-(define-public rust-universal-hash-0.4
-  (package
-    (inherit rust-universal-hash-0.5)
-    (name "rust-universal-hash")
-    (version "0.4.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "universal-hash" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "00hljq64l0p68yrncvyww4cdgkzpzl49vrlnj57kwblkak3b49l3"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-generic-array" ,rust-generic-array-0.14)
-        ("rust-subtle" ,rust-subtle-2))))))
-
-(define-public rust-universal-hash-0.3
-  (package
-    (inherit rust-universal-hash-0.4)
-    (name "rust-universal-hash")
-    (version "0.3.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "universal-hash" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "00aa241pab99z66f0s464vdrxnk3igs8z1qm6j01chcv5w7r036z"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-generic-array" ,rust-generic-array-0.12)
-        ("rust-subtle" ,rust-subtle-2))))))
-
 (define-public rust-unix-socket-0.5
   (package
     (name "rust-unix-socket")