summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 16:02:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:00 +0200
commitdcd1b5b031674ac549f2fae8828b8fb771b9a450 (patch)
tree06260143d46b02351cac00d6daf15527055a7d74 /gnu
parentf78a25fb7807a33d858d678bd02862ca5dc6a776 (diff)
downloadguix-dcd1b5b031674ac549f2fae8828b8fb771b9a450.tar.gz
gnu: rust-salsa20: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-salsa20-0.10, rust-salsa20-0.9,
rust-salsa20-0.7): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: I219444064c8a4acbcc6b51d37c2b3c6aabf5134d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-crypto.scm61
-rw-r--r--gnu/packages/crates-io.scm66
2 files changed, 61 insertions, 66 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 83d648163e..f515ab3455 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3634,6 +3634,67 @@ Digital Signature Algorithm} (ECDSA).")
          ("rust-sha2" ,rust-sha2-0.9)
          ("rust-sha3" ,rust-sha3-0.9))))))
 
+(define-public rust-salsa20-0.10
+  (package
+    (name "rust-salsa20")
+    (version "0.10.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "salsa20" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "04w211x17xzny53f83p8f7cj7k2hi8zck282q5aajwqzydd2z8lp"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-cipher" ,rust-cipher-0.4))
+       #:cargo-development-inputs
+       (("rust-cipher" ,rust-cipher-0.4)
+        ("rust-hex-literal" ,rust-hex-literal-0.3))))
+    (home-page "https://github.com/RustCrypto/stream-ciphers")
+    (synopsis "Salsa20 Stream Cipher")
+    (description "Salsa20 is a collection of stream cipher algorithms written
+in pure Rust.")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-salsa20-0.9
+  (package
+    (inherit rust-salsa20-0.10)
+    (name "rust-salsa20")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "salsa20" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "11i646kpgimimqiq8hyi0b7ngp588f7nl9xsc317d9kdcxgvn3qc"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-cipher" ,rust-cipher-0.3)
+        ("rust-zeroize" ,rust-zeroize-1))))))
+
+(define-public rust-salsa20-0.7
+  (package
+    (inherit rust-salsa20-0.10)
+    (name "rust-salsa20")
+    (version "0.7.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "salsa20" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "09c16m566g45f41xx3673zyzwca3mykz630fmv2mbjbvmwcc4fw0"))))
+    (arguments
+      `(#:cargo-inputs
+        (("rust-cipher" ,rust-cipher-0.2)
+         ("rust-zeroize" ,rust-zeroize-1))
+        #:cargo-development-inputs
+        (("rust-cipher" ,rust-cipher-0.2))))))
+
 (define-public rust-sha-1-0.10
   (package
     (name "rust-sha-1")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7d032f775a..5f4ef77284 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -59708,48 +59708,6 @@ quickly convert floating point numbers to decimal strings.")
      "This package provides a procedural macros for the salsa crate.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-salsa20-0.10
-  (package
-    (name "rust-salsa20")
-    (version "0.10.2")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "salsa20" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "04w211x17xzny53f83p8f7cj7k2hi8zck282q5aajwqzydd2z8lp"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cipher" ,rust-cipher-0.4))
-       #:cargo-development-inputs
-       (("rust-cipher" ,rust-cipher-0.4)
-        ("rust-hex-literal" ,rust-hex-literal-0.3))))
-    (home-page "https://github.com/RustCrypto/stream-ciphers")
-    (synopsis "Salsa20 Stream Cipher")
-    (description "Salsa20 is a collection of stream cipher algorithms written
-in pure Rust.")
-    (license (list license:expat license:asl2.0))))
-
-(define-public rust-salsa20-0.9
-  (package
-    (inherit rust-salsa20-0.10)
-    (name "rust-salsa20")
-    (version "0.9.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "salsa20" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "11i646kpgimimqiq8hyi0b7ngp588f7nl9xsc317d9kdcxgvn3qc"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-cipher" ,rust-cipher-0.3)
-        ("rust-zeroize" ,rust-zeroize-1))))))
-
 (define-public rust-salsa-0.17
   (package
     (name "rust-salsa")
@@ -59794,30 +59752,6 @@ in pure Rust.")
 computation (experimental)")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-salsa20-0.7
-  (package
-    (name "rust-salsa20")
-    (version "0.7.1")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "salsa20" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32 "09c16m566g45f41xx3673zyzwca3mykz630fmv2mbjbvmwcc4fw0"))))
-    (build-system cargo-build-system)
-    (arguments
-      `(#:cargo-inputs
-        (("rust-cipher" ,rust-cipher-0.2)
-         ("rust-zeroize" ,rust-zeroize-1))
-        #:cargo-development-inputs
-        (("rust-cipher" ,rust-cipher-0.2))))
-    (home-page "https://github.com/RustCrypto/stream-ciphers")
-    (synopsis "Salsa20 stream cipher")
-    (description "This is a Rust library implementing the Salsa20 stream
-cipher.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-safe-arch-0.6
   (package
     (name "rust-safe-arch")