summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 21:37:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 22:09:32 +0200
commitdfeac7e4776f8d5fe93834b299dd8e51518018e0 (patch)
tree1fb34cc2a86c071ee098409b5fac9144d0bcf609 /gnu
parentb6f274eeacf686ea5fce06a0aa90b05e418ed3b2 (diff)
downloadguix-dfeac7e4776f8d5fe93834b299dd8e51518018e0.tar.gz
gnu: emacs-tree-inspector: Update to 0.4.
* gnu/packages/emacs-xyz.scm (emacs-tree-inspector): Update to 0.4.
[arguments]<#:phases>: Require `subr-x' library in order to prevent a test
failure (and probably a run-time failure) when `hash-table-keys' is called.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index de2c2a6ace..105ab44237 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -794,10 +794,10 @@ Common Lisp or Smalltalk, but for Emacs Lisp.")
       (license license:gpl3+))))
 
 (define-public emacs-tree-inspector
-  (let ((commit "495ef1874fba9d75842087f4acf0ebd75cf09e97"))
+  (let ((commit "bbb8d2dfe84fbf857fcc1579de5a1324b09a877e"))
     (package
       (name "emacs-tree-inspector")
-      (version "0.3")
+      (version "0.4")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -806,7 +806,7 @@ Common Lisp or Smalltalk, but for Emacs Lisp.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "011pk5gr2j9m4qnv70qz63bh58ga72nqahv0zkf2qpbr2a5df09c"))))
+                  "01ad4r97hfr9nndbifyggscb5108y7h2qm95jsmh5b9qgzqm39nx"))))
       (build-system emacs-build-system)
       (arguments
        (list
@@ -814,7 +814,17 @@ Common Lisp or Smalltalk, but for Emacs Lisp.")
         #:test-command #~(list "emacs" "-Q" "--batch"
                                "-L" "."
                                "-l" "tree-inspector-tests.el"
-                               "-f" "ert-run-tests-batch-and-exit")))
+                               "-f" "ert-run-tests-batch-and-exit")
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'fix-library-loading
+              ;; The library calls `hash-table-keys', which is not
+              ;; auto-loaded.  Explicitly require `subr-x', where it is
+              ;; defined.
+              (lambda _
+                (substitute* "tree-inspector.el"
+                  (("\\(require 'cl-lib\\)" line)
+                   (string-append line "(require 'subr-x)"))))))))
       (propagated-inputs (list emacs-treeview))
       (home-page "https://github.com/mmontone/emacs-tree-inspector")
       (synopsis "Inspection tool for Emacs Lisp objects that uses a tree view")