summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:41:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:50 +0200
commite649aa6ac40a589229cbf12cb5967802dd28ee14 (patch)
tree0b512c3a3e10efbc5fedf8b1777fae85a1b2f3b4 /gnu
parent889ba05ae91cae8b8e972ad2c5ceb512b7a27d07 (diff)
downloadguix-e649aa6ac40a589229cbf12cb5967802dd28ee14.tar.gz
gnu: Add texlive-xcite.
* gnu/packages/tex.scm (texlive-xcite): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 348e999317..feebb83d6f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18204,6 +18204,26 @@ Native American languages.")
      "This package provides LaTeX support for the @code{wnri} fonts.")
     (license license:gpl2)))
 
+(define-public texlive-xcite
+  (package
+    (name "texlive-xcite")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/xcite/" "source/latex/xcite/"
+                   "tex/latex/xcite/")
+             (base32
+              "1r6f4wk7d3na9a8v20kqp24m46rsqgqx0n8k5hv3ynhqhzizhpll")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/xcite")
+    (synopsis "Use citation keys from a different document")
+    (description
+     "The package @code{xcite} is no longer necessary, because its
+functionality has been taken over by @code{xr}, so this final version is just
+a stub that loads @code{xr}.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-xecjk
   (package
     (name "texlive-xecjk")