summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-10 23:32:09 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:36 +0800
commiteb5474bcbed6efef6924a79423ab263b093c53f4 (patch)
treec415d978256b45e93b0027e62f8e4741353ef28a /gnu
parent47be97c731afeebea459b1a58aea2bc0b56054a4 (diff)
downloadguix-eb5474bcbed6efef6924a79423ab263b093c53f4.tar.gz
gnu: Add qtlocation.
* gnu/packages/qt.scm (qtlocation): New variable.

Change-Id: I270399ee01718c5ea3e76a81ecdd81d14bc608fc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0f4bc06eb2..0138fd3dbf 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2300,6 +2300,32 @@ Server Protocol (LSP) for Qt.")
     (description "The Qt Location module provides an interface for location,
 positioning and geolocation plugins.")))
 
+(define-public qtlocation
+  (package
+    (inherit qtsvg)
+    (name "qtlocation")
+    (version "6.6.3")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-url name version))
+              (sha256
+               (base32
+                "1l81z3zq1zg015l6qxx4yzssdspw689m9bpzxp23yshaych2kd6p"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments qtsvg)
+       ((#:tests? _ #f) #f)             ; TODO: Enable the tests
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (add-before 'check 'pre-check
+              (lambda _
+                (setenv "HOME" "/tmp")))))))
+    (native-inputs (list perl))
+    (inputs (list icu4c openssl qtbase zlib qtdeclarative qtpositioning
+                  libxkbcommon))
+    (synopsis "Qt Location and Positioning modules")
+    (description "The Qt Location module provides an interface for location,
+positioning and geolocation plugins.")))
+
 (define-public qtlottie
   (package
     (name "qtlottie")