summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-03 14:44:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:10 +0300
commiteeea0ec0f29d0c1bbe1be3007226c1bb6dd9f814 (patch)
tree65be58dfea9d5913eded0571e7850cf97b22e42f /gnu
parent993c0ae6d2381d5ab0d683749cb5e15c088fa7fa (diff)
downloadguix-eeea0ec0f29d0c1bbe1be3007226c1bb6dd9f814.tar.gz
gnu: Add rust-y4m-0.8.
* gnu/packages/crates-graphics.scm (rust-y4m-0.8): New variable.
(rust-y4m-0.7): Inherit from rust-y4m-0.8.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm23
1 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index ba502982ad..04dee1ec09 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -3823,25 +3823,40 @@ the platform-specific getters provided by winit, or another library.")
     (description "This package provides X11 library bindings for Rust.")
     (license license:expat)))
 
-(define-public rust-y4m-0.7
+(define-public rust-y4m-0.8
   (package
     (name "rust-y4m")
-    (version "0.7.0")
+    (version "0.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "y4m" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1bhdgb7hgx7j92nm6ij5n8wisp50j8ff66ks14jzwdw2mwhrjam7"))))
+        (base32 "0j24y2zf60lpxwd7kyg737hqfyqx16y32s0fjyi6fax6w4hlnnks"))))
     (build-system cargo-build-system)
-    (arguments `(#:skip-build? #t))
+    (arguments
+     `(#:cargo-development-inputs (("rust-resize" ,rust-resize-0.4))))
     (home-page "https://github.com/image-rs/y4m")
     (synopsis "YUV4MPEG2 (@file{.y4m}) encoder and decoder")
     (description
      "This package provides a YUV4MPEG2 (@file{.y4m}) encoder and decoder.")
     (license license:expat)))
 
+(define-public rust-y4m-0.7
+  (package
+    (inherit rust-y4m-0.8)
+    (name "rust-y4m")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "y4m" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1bhdgb7hgx7j92nm6ij5n8wisp50j8ff66ks14jzwdw2mwhrjam7"))))
+    (arguments `(#:skip-build? #t))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar