summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:33:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:02 +0200
commitf1794522f91c7194dc78541fef28cf8a0793f6dd (patch)
tree8afd7c7e3a73b539a804033b029bf1adf8b84cf7 /gnu
parent0dbff50cfa6007b52568a735a8121de42b4f5813 (diff)
downloadguix-f1794522f91c7194dc78541fef28cf8a0793f6dd.tar.gz
gnu: Add texlive-scientific-thesis-cover.
* gnu/packages/tex.scm (texlive-scientific-thesis-cover): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fbcba627a6..24502bba92 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -26850,6 +26850,26 @@ Lateinische Ausgangsschrift, Schulausgangsschrift, and Vereinfachte
 Ausgangsschrift.")
     (license license:lppl)))
 
+(define-public texlive-scientific-thesis-cover
+  (package
+    (name "texlive-scientific-thesis-cover")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/scientific-thesis-cover/"
+                   "source/latex/scientific-thesis-cover/"
+                   "tex/latex/scientific-thesis-cover/")
+             (base32
+              "1ny19pczzrrwb20sin1qn914hy1npwxkx573g3n5gm62kzl1vc4k")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/scientific-thesis-cover")
+    (synopsis "Provides cover page and affirmation at the end of a thesis")
+    (description
+     "Institutions require a cover page and an affirmation at the end of
+a thesis.  This package provides both.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-shobhika
   (package
     (name "texlive-shobhika")