summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-03 07:43:09 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:32 +0200
commitf8619a64e5ed634d3c91d4857338f4c6b0b3675a (patch)
treef5f39062d40498eebd98e64105fe2b466791e32e /gnu
parent3245258fe2e17829d1dd91fe7ab83d486afa118d (diff)
downloadguix-f8619a64e5ed634d3c91d4857338f4c6b0b3675a.tar.gz
gnu: font-go: Install license files.
* gnu/packages/fonts.scm (font-go)[arguments]<#:license-file-regexp>: Add.
<#:phases>: Add "enter-license-directory" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fonts.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index cb565296e6..10cc23f497 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2219,12 +2219,16 @@ and stylistic alternates.")
                   "1aq6mnjayks55gd9ahavk6jfydlq5lm4xm0xk4pd5sqa74p5p74d"))))
       (build-system font-build-system)
       (arguments
-       `(#:phases
+       `(#:license-file-regexp "^(LICENSE|PATENTS)$"
+         #:phases
          (modify-phases %standard-phases
            (add-before 'install 'chdir
              (lambda _
                (chdir "font/gofont/ttfs")
-               #t)))))
+               #t))
+           (add-before 'install-license-files 'enter-license-directory
+             (lambda _
+               (chdir "../../.."))))))
       (home-page "https://blog.golang.org/go-fonts")
       (synopsis "The Go font family")
       (description