summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-03-30 14:16:41 +0200
committerJelle Licht <jlicht@fsfe.org>2023-05-06 13:53:22 +0200
commitf963ac4f63918507f7adec6590162d5c4b47c040 (patch)
treeea4bf637945bbb3d9c777b0d9a44d2e123a45a18 /gnu
parent2c8c582803f87ac0690fabe44a380ee782ea894d (diff)
downloadguix-f963ac4f63918507f7adec6590162d5c4b47c040.tar.gz
gnu: node-openzwave-shared: Fix compilation for new versions of node
* gnu/packages/zwave.scm (node-openzwave-shared)[arguments]<#:phases>: Add
patch-compiler phase to allow compilation with node versions 16 and up.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/zwave.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/zwave.scm b/gnu/packages/zwave.scm
index 3e99bd7687..a30199ec02 100644
--- a/gnu/packages/zwave.scm
+++ b/gnu/packages/zwave.scm
@@ -112,6 +112,11 @@ knowledge of the Z-Wave protocol.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-before 'build 'patch-compiler
+           (lambda _
+             (substitute* "binding.gyp"
+               (("std=c\\+\\+11")
+                "std=c++17"))))
          (replace 'build
            ;; For some reason, `npm install` doesn't build
            ;; the addon automatically, so we do it explicitly here.