summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:06 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:55 +0000
commitfa0c8e82608d51aadd9436e0351d2415924921bb (patch)
tree7b351b3b40d22759ceced555dfcfdd81fdf596ee /gnu
parent89c1bc291e2e1ef860b7cad182b2433eebd4beaa (diff)
downloadguix-fa0c8e82608d51aadd9436e0351d2415924921bb.tar.gz
gnu: Add ocaml-mirage-profile.
* gnu/packages/ocaml.scm (ocaml-mirage-profile): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e4f7b929a1..061654facd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3884,6 +3884,20 @@ will optimise these calls away, meaning there should be no overhead in the
 non-profiling case.")
     (license license:bsd-2)))
 
+(define-public ocaml-mirage-profile
+  (package
+    (inherit ocaml-mirage-profile-unix)
+    (name "ocaml-mirage-profile")
+    (arguments
+     '(#:package "mirage-profile"
+       ;; TODO cyclic dependency with mirage-profile
+       ;; It could be broken using package variants, if not for
+       ;; propagated inputs leading to version conflicts.
+       #:tests? #f))
+    (propagated-inputs (modify-inputs (package-propagated-inputs
+                                       ocaml-mirage-profile-unix)
+                         (append ocaml-mirage-profile-unix)))))
+
 (define-public ocaml-ocurl
   (package
     (name "ocaml-ocurl")