summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-13 17:01:53 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-03 18:05:09 -0400
commitfa2fe542c33e7407286ef02779fbdcac77f67861 (patch)
treed2ac2a9bc0177a52856f582380c7e45ca1926212 /gnu
parent83da3a13bfb107e7274a91766efa9f41c9e692b3 (diff)
downloadguix-fa2fe542c33e7407286ef02779fbdcac77f67861.tar.gz
gnu: Add qtsensors.
* gnu/packages/qt.scm (qtsensors): New variable.

Change-Id: I5d5bf3902f3340d6e73dc8889e27d4e5bf28b058
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 191c319f35..5bf97e6c54 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1728,6 +1728,24 @@ consume data received from the server, or both.")
     (home-page (package-home-page qtbase))
     (license (package-license qtbase))))
 
+(define-public qtsensors
+  (package
+    (inherit qtsvg)
+    (name "qtsensors")
+    (version "6.6.2")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-url name version))
+              (sha256
+               (base32
+                "0a3w50bfnmxndyxnn9lsy1wxffhm2am0yjxqx3vx0gfjwv79yvsa"))))
+    (native-inputs (list qtdeclarative))
+    (inputs (list qtbase))
+    (synopsis "Qt Sensors module")
+    (description "The Qt Sensors API provides access to sensor hardware via QML
+and C++ interfaces.  The Qt Sensors API also provides a motion gesture
+recognition API for devices.")))
+
 (define-public qtsensors-5
   (package
     (inherit qtsvg-5)