summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-03-28 13:27:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-03-28 13:27:04 +0100
commitfb9549164520ad993c2fbbaedc899844d57baabc (patch)
treee666668f00229ea9ba958e0b44e9e1fe669708d2 /gnu
parent1da36e4db925addecbd49a504752d9efb9b6eb7e (diff)
downloadguix-fb9549164520ad993c2fbbaedc899844d57baabc.tar.gz
gnu: python-pynacl: Use pyproject-build-system.
* gnu/packages/python-crypto.scm (python-pynacl)[build-system]: Use
pyproject-build-system.
[arguments]: Remove custom check phase.
[source]: Remove unnecessary substitution.

Change-Id: Idf2409022abde9f3a59e71cd1fa69ce9f1df6b1f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 374724e8a4..3e1472a6c9 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -11,7 +11,7 @@
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017, 2019, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2019, 2022, 2024 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2016, 2017, 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -782,25 +782,19 @@ PKCS#12, PKCS#5, X.509 and TSP.")
        (modules '((guix build utils)))
        (snippet
         '(begin
-           ;; Remove spurious dependency on python-wheel, can be removed
-           ;; for 1.5.
-           (substitute* "setup.py"
-             (("\"wheel\"") ""))
            ;; Remove bundled libsodium.
            (delete-file-recursively "src/libsodium")))
        (sha256
         (base32
          "1fi0jbxhh3svajzldlb6gj5sr5a48v11xlmx0wb831db167l9iwa"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
+     (list
+      #:phases
+      '(modify-phases %standard-phases
          (add-before 'build 'use-system-sodium
            (lambda _
-             (setenv "SODIUM_INSTALL" "system")))
-         (replace 'check
-           (lambda _
-             (invoke "pytest" "-vv"))))))
+             (setenv "SODIUM_INSTALL" "system"))))))
     (native-inputs
      (list python-hypothesis python-pytest))
     (propagated-inputs