summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 13:06:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:51 +0200
commitfe7f3f80d9e4e827f9fbf05cd3179d19f6461613 (patch)
treec9e51d69a2358dfcf3ab017c87aa1a147c1ee054 /gnu
parent841b8472eea97d734e8fee6c3bbdec892ebbc838 (diff)
downloadguix-fe7f3f80d9e4e827f9fbf05cd3179d19f6461613.tar.gz
gnu: Add texlive-umtypewriter.
* gnu/packages/tex.scm (texlive-umtypewriter): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a0cf09a867..0d1556fb57 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25339,6 +25339,27 @@ providing the LaTeX user with macros which are used to markup textual
 information.")
     (license license:lppl)))
 
+(define-public texlive-umtypewriter
+  (package
+    (name "texlive-umtypewriter")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/umtypewriter/"
+                   "fonts/opentype/public/umtypewriter/")
+             (base32
+              "19skqmchglac4lrk4qhvb4rabi73qmypdi20sbjxnvb8abw0pf3i")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/umtypewriter")
+    (synopsis "Fonts to typeset with the @code{xgreek} package")
+    (description
+     "The UMTypewriter font family is a monospaced font family that was built
+from glyphs from the CB Greek fonts, the CyrTUG Cyrillic alphabet fonts (LH),
+and the standard Computer Modern font family.  It contains four OpenType fonts
+which are required for use of the @code{xgreek} package for XeLaTeX.")
+    (license license:silofl1.1)))
+
 (define-public texlive-unfonts-core
   (package
     (name "texlive-unfonts-core")