summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 00:54:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 00:55:01 +0100
commitfeb50ac6dc34ea88f33958b08c967ed99234868e (patch)
tree331be7d6dd3c4a6f01e0b8f4b174bb3025c9d068 /gnu
parenta8a96bbead267946e29554de13490b93fe01ec5c (diff)
downloadguix-feb50ac6dc34ea88f33958b08c967ed99234868e.tar.gz
gnu: l-abbaye-des-morts: Don't use unstable tarball.
This also fixes a build failure due to the use of NAME.

* gnu/packages/games.scm (l-abbaye-des-morts)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 10aa1da972..4b3cedb936 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1269,13 +1269,13 @@ can be explored and changed freely.")
     (version "2.0.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/nevat/abbayedesmorts-gpl/"
-                           "archive/v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nevat/abbayedesmorts-gpl.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1a67b0hq6271dd7pvwndjq29cwn2n8gawwz17xafa3k1hrhf8vw3"))
+        (base32 "1pwqf7r9bqb2p3xrw9i7y8pgr1401fy3mnnqpb1qkhmdl3gqi9hb"))
        (modules '((guix build utils)))
        (snippet
         ;; Unbundle fonts.