summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorYovan Naumovski <yovan@gorski.stream>2023-04-05 22:01:41 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:29:25 -0400
commit19799efe4f6d8c1fe0f8b94a98ac1d1eb3c2f0e9 (patch)
tree4fe8c400bf8245aeee94df8437392daf2c6cdce3 /gnu
parent6b835914c120c2d89c38a70573130415e28686e6 (diff)
downloadguix-19799efe4f6d8c1fe0f8b94a98ac1d1eb3c2f0e9.tar.gz
gnu: ruby-pg: Update to 1.4.6.
* gnu/packages/ruby.scm (ruby-pg): Update to 1.4.6.
[arguments]: Remove DISABLE-FAILING-TESTS phase, the tests pass without it.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index acc8dc1af8..377317a993 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7804,16 +7804,6 @@ alternative to Marshal for Object serialization.")
       #:test-target "spec"
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'disable-failing-tests
-            (lambda _
-              ;; These tests fail because DNS is unavailable, giving an
-              ;; unexpected fallback executable in the connection string.
-              (substitute* "spec/pg/connection_spec.rb"
-                (("it (\"accepts an URI and adds( proper)? hostaddr\")" test)
-                 (string-append "xit " test))
-                (("it \"can create a connection option string from an option\
- string and a hash\"" test)
-                 (string-append "xit " test)))))
                (add-before 'build 'compile
                  (lambda _
                    (invoke "rake" "compile")))
@@ -7833,7 +7823,7 @@ alternative to Marshal for Object serialization.")
     (inputs (list postgresql))
     (synopsis "Ruby interface to PostgreSQL")
     (description "Pg is the Ruby interface to the PostgreSQL RDBMS.  It works
-with PostgreSQL 9.0 and later.")
+with PostgreSQL 9.3 and later.")
     (license license:ruby)))
 
 (define-public ruby-byebug