summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-16 17:10:13 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 18:32:12 +0200
commit1f22184b2236996b5ef20fbcfa7805f94250a147 (patch)
treeb8d6404e7c45d04c558f0382f08a6a862e958858 /gnu
parent13040cd3099ed6071e96595784ea66c8920bb1f8 (diff)
downloadguix-1f22184b2236996b5ef20fbcfa7805f94250a147.tar.gz
gnu: python-attrs: Disable test deadline on all architectures.
* gnu/packages/python-xyz.scm (python-attrs)[arguments]: Remove conditional.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0885d976bd..62ca287449 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19000,15 +19000,12 @@ from the header, as well as section details and data available.")
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
-                  ,@(if (target-riscv64?)
-                      ;; TODO: Remove the conditional on staging.
-                      `((add-after 'unpack 'remove-test-hypothesis-deadlines
-                          (lambda _
-                            (substitute* "tests/test_make.py"
-                              (("assume, given") "assume, given, settings")
-                              (("( +)@given" all spaces)
-                               (string-append spaces "@settings(deadline=None)\n" all))))))
-                      '())
+                  (add-after 'unpack 'remove-test-hypothesis-deadlines
+                    (lambda _
+                      (substitute* "tests/test_make.py"
+                        (("assume, given") "assume, given, settings")
+                        (("( +)@given" all spaces)
+                         (string-append spaces "@settings(deadline=None)\n" all)))))
                   (replace 'check
                     (lambda* (#:key tests? #:allow-other-keys)
                       (when tests?