summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-04-27 17:06:53 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-04-30 11:50:50 +0200
commit300200b6370c3ab506df202853602dccb7368b6c (patch)
treeb40bac01d14aef368ffe1dc9711dd3a796ab3556 /gnu
parent06be316111b70fb46aa4ee77f2fbf9e6308a2fb6 (diff)
downloadguix-300200b6370c3ab506df202853602dccb7368b6c.tar.gz
gnu: Add netcdf-fortran.
* gnu/packages/maths.scm (netcdf-fortran): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0a11da9eaf..4e70bd8d1c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -850,6 +850,30 @@ sharing of scientific data.")
                 "--disable-shared" "--with-pic"
                 ,flags))))))
 
+(define-public netcdf-fortran
+  (package
+    (name "netcdf-fortran")
+    (version "4.4.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "ftp://ftp.unidata.ucar.edu/pub/netcdf/netcdf-fortran-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0xaxdcg1p83zmypwml3swsnr3ccn38inwldyr1l3wa4dbwbrblxj"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:parallel-tests? #f))
+    (inputs
+     `(("netcdf" ,netcdf)))
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (synopsis "Fortran interface for the netCDF library")
+    (description (package-description netcdf))
+    (home-page (package-home-page netcdf))
+    (license (package-license netcdf))))
+
 (define-public nlopt
   (package
     (name "nlopt")