summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-04 15:34:13 +0100
committerLeo Famulari <leo@famulari.name>2021-12-28 14:10:11 -0500
commit38df88ac1262a6cf4aa2f3ff75e00f8c142b9527 (patch)
tree8784cf7962c2c4684744ea3e9c656158937a1ddd /gnu
parent6daae4eb970adc960fff60e004a75a7b5d315a1d (diff)
downloadguix-38df88ac1262a6cf4aa2f3ff75e00f8c142b9527.tar.gz
gnu: Add rust-arrow2-0.7.
* gnu/packages/crates-io.scm (rust-arrow2-0.7): New variable.
(rust-arrow2-0.5): Inherit from above.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm58
1 files changed, 52 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index eb87db09e3..7d5cf32be2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2718,28 +2718,29 @@ format.")
 code of Apache Arrow spec.")
     (license license:asl2.0)))
 
-(define-public rust-arrow2-0.5
+(define-public rust-arrow2-0.7
   (package
     (name "rust-arrow2")
-    (version "0.5.3")
+    (version "0.7.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "arrow2" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "042m859jfffnhi84qc919pkyanlr98wqqf67pcrylk4hhh0v84xx"))))
+        (base32 "15dkirkx07bagjgcar2ikmvs0d1zsk5l99bsszla91rxbivy4wyq"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-ahash" ,rust-ahash-0.7)
+        ("rust-arrow-format" ,rust-arrow-format-0.3)
+        ("rust-avro-rs" ,rust-avro-rs-0.13)
         ("rust-base64" ,rust-base64-0.13)
         ("rust-chrono" ,rust-chrono-0.4)
-        ("rust-chrono-tz" ,rust-chrono-tz-0.5)
+        ("rust-chrono-tz" ,rust-chrono-tz-0.6)
         ("rust-comfy-table" ,rust-comfy-table-4)
         ("rust-csv" ,rust-csv-1)
-        ("rust-flatbuffers" ,rust-flatbuffers-2)
         ("rust-futures" ,rust-futures-0.3)
         ("rust-hash-hasher" ,rust-hash-hasher-2)
         ("rust-hex" ,rust-hex-0.4)
@@ -2747,16 +2748,18 @@ code of Apache Arrow spec.")
         ("rust-itertools" ,rust-itertools-0.10)
         ("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-lexical-core" ,rust-lexical-core-0.8)
+        ("rust-libflate" ,rust-libflate-1)
         ("rust-lz4" ,rust-lz4-1)
         ("rust-multiversion" ,rust-multiversion-0.6)
         ("rust-num-traits" ,rust-num-traits-0.2)
         ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
-        ("rust-parquet2" ,rust-parquet2-0.4)
+        ("rust-parquet2" ,rust-parquet2-0.6)
         ("rust-rand" ,rust-rand-0.8)
         ("rust-regex" ,rust-regex-1)
         ("rust-serde" ,rust-serde-1)
         ("rust-serde-derive" ,rust-serde-derive-1)
         ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-simdutf8" ,rust-simdutf8-0.1)
         ("rust-streaming-iterator" ,rust-streaming-iterator-0.1)
         ("rust-strength-reduce" ,rust-strength-reduce-0.2)
         ("rust-zstd" ,rust-zstd-0.9))))
@@ -2767,6 +2770,49 @@ code of Apache Arrow spec.")
 a re-write of the official Arrow crate using transmute-free operations.")
     (license license:asl2.0)))
 
+(define-public rust-arrow2-0.5
+  (package
+    (inherit rust-arrow2-0.7)
+    (name "rust-arrow2")
+    (version "0.5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "arrow2" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "042m859jfffnhi84qc919pkyanlr98wqqf67pcrylk4hhh0v84xx"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-ahash" ,rust-ahash-0.7)
+        ("rust-base64" ,rust-base64-0.13)
+        ("rust-chrono" ,rust-chrono-0.4)
+        ("rust-chrono-tz" ,rust-chrono-tz-0.5)
+        ("rust-comfy-table" ,rust-comfy-table-4)
+        ("rust-csv" ,rust-csv-1)
+        ("rust-flatbuffers" ,rust-flatbuffers-2)
+        ("rust-futures" ,rust-futures-0.3)
+        ("rust-hash-hasher" ,rust-hash-hasher-2)
+        ("rust-hex" ,rust-hex-0.4)
+        ("rust-indexmap" ,rust-indexmap-1)
+        ("rust-itertools" ,rust-itertools-0.10)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-lexical-core" ,rust-lexical-core-0.8)
+        ("rust-lz4" ,rust-lz4-1)
+        ("rust-multiversion" ,rust-multiversion-0.6)
+        ("rust-num-traits" ,rust-num-traits-0.2)
+        ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
+        ("rust-parquet2" ,rust-parquet2-0.4)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-regex" ,rust-regex-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-streaming-iterator" ,rust-streaming-iterator-0.1)
+        ("rust-strength-reduce" ,rust-strength-reduce-0.2)
+        ("rust-zstd" ,rust-zstd-0.9))))))
+
 (define-public rust-article-scraper-1
   (package
     (name "rust-article-scraper")