summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:41 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:32 +0200
commit5bbd9abdbb39ff4e614ede735bd84f63fa410257 (patch)
tree87483c6e6d9070e392cef58837671dd024df8652 /gnu
parentfb2391a47965d80ea49a3a335551de3d18144073 (diff)
downloadguix-5bbd9abdbb39ff4e614ede735bd84f63fa410257.tar.gz
gnu: Add trytond-sale-payment.
* gnu/packages/tryton.scm (trytond-sale-payment): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 5432b06953..a54b53ef5e 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3262,6 +3262,32 @@ option to define how invoice lines generated from sales will be grouped.")
 lead/opportunity model.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-payment
+  (package
+    (name "trytond-sale-payment")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_payment" version))
+       (sha256
+        (base32 "0i38766m9a0arhwybsqgk11zmmr982mmcsn0fswq695gb0zlwl0f"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_payment"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-payment-clearing" ,trytond-account-payment-clearing)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-account-payment" ,trytond-account-payment)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-payment")
+    (synopsis "Tryton module that manage payments on sale")
+    (description "The @emph{Sale Payment} Tryton module extends Sale to allow
+payments prior to the creation of any invoice.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")