summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commit725a31725df3c73691198c30384a01fc4806d821 (patch)
tree6f98b56f983d11d4f7793e9a1530e4bbb8207c94 /gnu
parent511c5fe65870c2231bf8c6c7dce179b6692fe6f2 (diff)
downloadguix-725a31725df3c73691198c30384a01fc4806d821.tar.gz
gnu: Add trytond-sale-amendment.
* gnu/packages/tryton.scm (trytond-sale-amendment): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 53b2ece72e..8f96ecab4e 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3031,6 +3031,32 @@ to be generated that contain aggregated sales figures.")
 for advance payment management on the sale.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-amendment
+  (package
+    (name "trytond-sale-amendment")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_amendment" version))
+       (sha256
+        (base32 "1vkcyfp30hng2vj1h1pvwrlvp9b59pkzzlmgnj6gvs867l8f2zva"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_amendment"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-sale-history" ,trytond-sale-history)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-amendment")
+    (synopsis "Tryton module to amend sales")
+    (description "The @emph{Sale Amendment} Tryton module allows you to change
+sales that are being processed and keep track of the changes.  An amendment is
+composed of action lines which can:")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")