summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-14 18:08:46 +0200
committerMarius Bakke <marius@gnu.org>2022-06-14 23:33:53 +0200
commit73e0063888db5ecfa74f16dccde0632b4ff1b95e (patch)
tree7fa28d7c2b9ddea167fb19f095d75d4e606631db /gnu
parentd73b88d82650f8e38327dcd1c7a0c9da4fc96e0f (diff)
downloadguix-73e0063888db5ecfa74f16dccde0632b4ff1b95e.tar.gz
gnu: python-josepy: Update to 1.13.0.
* gnu/packages/python-crypto.scm (python-josepy): Update to 1.13.0.
[propagated-inputs]: Remove PYTHON-SIX.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 84e9102bee..f2059dbbf5 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -871,29 +871,19 @@ Python.")
 (define-public python-josepy
   (package
     (name "python-josepy")
-    (version "1.1.0")
+    (version "1.13.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "josepy" version))
               (sha256
                (base32
-                "11khz8malzrv375b27jjkv66z6z6khdx1v5mkkr4vq16gp3n4p7v"))))
+                "1jaxqyp53paks2z8zyzr50gqvzfxbar7r2qf98kqak4aizrxlcc9"))))
     (build-system python-build-system)
     (arguments
-     ;; The tests require flake8 >= 3.5, which is not yet packaged.
+     ;; TODO: some test dependencies are missing (see pyproject.toml).
      '(#:tests? #f))
     (propagated-inputs
-     (list python-cryptography python-pyopenssl python-six))
-;; TODO Enable when we have flake8 >= 3.5.
-;    (native-inputs
-;     `(("python-coverage" ,python-coverage)
-;       ("python-flake8" ,python-flake8)
-;       ("python-isort" ,python-isort)
-;       ("python-mock" ,python-mock)
-;       ("python-pytest" ,python-pytest)
-;       ("python-pytest-cov" ,python-pytest-cov)
-;       ("python-pytest-cache" ,python-pytest-cache)
-;       ("python-pytest-flake8" ,python-pytest-flake8)))
+     (list python-cryptography python-pyopenssl))
     (home-page "https://github.com/certbot/josepy")
     (synopsis "JOSE protocol implementation in Python")
     (description "This package provides a Python implementation of the JOSE