summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 11:40:26 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:55 +0200
commit85009bedebdd5cb4d1c9f88db294217b642f0504 (patch)
tree9379e53897c9b3abea806f63467e7762dc1e526b /gnu
parent85750427032af6974957a2d470ec230490ab1748 (diff)
downloadguix-85009bedebdd5cb4d1c9f88db294217b642f0504.tar.gz
gnu: python-sortedcontainers: Update to 2.4.0.
* gnu/packages/python-xyz.scm (python-sortedcontainers): Update to 2.4.0.
[propagated-inputs]: Remove.
[home-page]: Update to current.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 097fed874d..860e10adb9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23059,25 +23059,19 @@ that is accessible to other projects developed in Cython.")
 (define-public python-sortedcontainers
   (package
     (name "python-sortedcontainers")
-    (version "2.1.0")
+    (version "2.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "sortedcontainers" version))
        (sha256
         (base32
-         "0fm0w5id2yhqld95hg2m636vjgkz377rvgdfqaxc25vbylr9lklp"))))
+         "126vpywl7aly6zir033a9indgyficlzl68qls61nn2y3djhabji5"))))
     (build-system python-build-system)
     (arguments
-     ;; FIXME: Tests require many extra dependencies, and would introduce
-     ;; a circular dependency on hypothesis, which uses this package.
+     ;; TODO: Circular dependency on pytest.
      '(#:tests? #f))
-    (propagated-inputs
-     `(("python-appdirs" ,python-appdirs)
-       ("python-distlib" ,python-distlib)
-       ("python-filelock" ,python-filelock)
-       ("python-six" ,python-six-bootstrap)))
-    (home-page "http://www.grantjenks.com/docs/sortedcontainers/")
+    (home-page "https://grantjenks.com/docs/sortedcontainers/")
     (synopsis "Sorted List, Sorted Dict, Sorted Set")
     (description
      "This package provides a sorted collections library, written in