summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-03-22 13:57:11 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-30 23:15:13 -0400
commit8af64f3963366b4800b3d8cc84c94edb9f5eaac0 (patch)
treede4ba55786efe9c6ca096c4c012afdebf1cba39d /gnu
parentcca7f2d7aef99e7a2624c61bdfdb94e94ffa316f (diff)
downloadguix-8af64f3963366b4800b3d8cc84c94edb9f5eaac0.tar.gz
gnu: Add hdf5@1.14.
* gnu/packages/maths.scm (hdf5-1.14): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9c8f1d89e2..3a5b2d4863 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1551,6 +1551,26 @@ extremely large and complex data collections.")
         (base32 "1zlawdzb0gsvcxif14fwr5ap2gk4b6j02wirr2hcx8hkcbivp20s"))
        (patches (search-patches "hdf5-config-date.patch"))))))
 
+(define-public hdf5-1.14
+  (package
+    (inherit hdf5-1.8)
+    (version "1.14.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+                                 "hdf5-" (version-major+minor version)
+                                 "/hdf5-" version "/src/hdf5-"
+                                 version ".tar.bz2")
+                  (string-append "https://support.hdfgroup.org/ftp/HDF5/"
+                                 "current"
+                                 (apply string-append
+                                        (take (string-split version #\.) 2))
+                                 "/src/hdf5-" version ".tar.bz2")))
+       (sha256
+        (base32 "181bdh8hp7v9xqwcby3lknr92lxlicc2hqscba3f5nhf8lrr9rz4"))
+       (patches (search-patches "hdf5-config-date.patch"))))))
+
 (define-public hdf5
   ;; Default version of HDF5.
   hdf5-1.10)