summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-11 21:33:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-12 09:24:48 +0200
commit8c380a01a27f0c52173473ba89c9325dff4e5b00 (patch)
treecd63107cddbe4efe0fabd208b8f5d6ce2d9fe54c /gnu
parente200de5457262877cc4bc13bd2723004a2c89963 (diff)
downloadguix-8c380a01a27f0c52173473ba89c9325dff4e5b00.tar.gz
gnu: Add dav1d.
* gnu/packages/video.scm (dav1d): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 15702b4e2a..2672a01ea4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3264,3 +3264,23 @@ API.  It includes bindings for Python, Ruby, and other languages.")
 helps you create the film you have always dreamed of.  Easily add sub-titles,
 transitions, and effects and then export your film to many common formats.")
     (license license:gpl3+)))
+
+(define-public dav1d
+  (package
+    (name "dav1d")
+    (version "0.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://downloads.videolan.org/pub/videolan/"
+                            "dav1d/" version "/dav1d-" version ".tar.xz"))
+        (sha256
+         (base32
+          "0dw0liday8cbyrirhm6bgzhxg4cdy66nspfkdlq338gdsfqcvrsc"))))
+    (build-system meson-build-system)
+    (native-inputs `(("nasm" ,nasm)))
+    (home-page "https://code.videolan.org/videolan/dav1d")
+    (synopsis "AV1 decoder")
+    (description "dav1d is a new AV1 cross-platform decoder, and focused on
+speed and correctness.")
+    (license license:bsd-2)))