summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-04 10:48:13 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-04 10:53:45 +0100
commit8c68cdecfba893b292b2e7797d8bb3f0492d83a1 (patch)
tree7ef8d4ba86d1ac646069319ee169cd70d9268067 /gnu
parent1d3098fc3bfd6cddc38c359c5e834ee2974c99ec (diff)
downloadguix-8c68cdecfba893b292b2e7797d8bb3f0492d83a1.tar.gz
gnu: emacs-embark: Update to 0.19.
* gnu/packages/emacs-xyz.scm (emacs-embark): Update to 0.19.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f68f5bce2a..bb0d2698df 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10124,28 +10124,25 @@ them easier to distinguish from other, less important buffers.")
     (license license:expat)))
 
 (define-public emacs-embark
-  ;; XXX: Upstream did not tag last release.  Use commit matching version
-  ;; bump.
-  (let ((commit "09da327d43793f0b30114ee80d82ef587124462a"))
-    (package
-      (name "emacs-embark")
-      (version "0.18")
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/oantolin/embark")
-               (commit commit)))
-         (sha256
-          (base32 "0drzsa9rzjy0548pa161cf1d71lnyjri31rkwyjray9gy2adbnhv"))
-         (file-name (git-file-name name version))))
-      (build-system emacs-build-system)
-      (propagated-inputs
-       (list emacs-avy emacs-consult))
-      (home-page "https://github.com/oantolin/embark")
-      (synopsis "Emacs mini-buffer actions rooted in keymaps")
-      (description
-       "This package provides a sort of right-click contextual menu for Emacs
+  (package
+    (name "emacs-embark")
+    (version "0.19")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/oantolin/embark")
+             (commit version)))
+       (sha256
+        (base32 "05c8p7rqv9p8p3nhgcjfr66hpsqazhnhwsnfdapxd9z7wrybqbg5"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     (list emacs-avy emacs-consult))
+    (home-page "https://github.com/oantolin/embark")
+    (synopsis "Emacs mini-buffer actions rooted in keymaps")
+    (description
+     "This package provides a sort of right-click contextual menu for Emacs
 offering you relevant @emph{actions} to use on a @emph{target} determined by
 the context.
 
@@ -10159,7 +10156,7 @@ get offered actions like deleting, copying, renaming, visiting in another
 window, running a shell command on the file, etc.  For buffers the actions
 include switching to or killing the buffer.  For package names the actions
 include installing, removing or visiting the homepage.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-prescient
   (package